Don
Faire un don pour aider au developpement de WiPhA

Recherche




Préférences

Se reconnecter
---

Votre nom (ou pseudo) :

Votre code secret


 Nombre de membres 126 membres


Connectés :

( personne )
Visites

 2318275 visiteurs

 12 visiteurs en ligne

forum.gifForum - External Editor - Sujet n°303

Forum - Forum
External Editor - External Editor


actif  Sujet n° 303  Hot key disable/customization

le 29/12/2010 @ 01:54
par twilson

Anonyme

visiteur

Is there any way to disable or change the hotkey (Ctrl-E) for invoking the external editor?  I use emacs as my external editor, and I've already changed Gnome to use emacs keybindings, and so Ctrl-E in my compose window is supposed to move me to the end of the current line.  Instead, it's now invoking the external editor.  One can always invoke the editor via the keyboard using the sequence Meta-T+e (i.e., Tools -> Edit in External Editor), so I'm fine with the hotkey being disabled altogether, but if I could change it to something else, that would be good, too.
  Poster une réponse  Haut
Réponse n° 1
--------
le 04/01/2011 @ 06:53
par twilson

Anonyme

visiteur
After not receiving an answer to my question for some time, I decided to look into the source code myself.  I found a way to disable the hotkey which I give here (caveat:  I'm using Thunderbird 3.1 on Ubuntu):

1.  The source archive is called "exteditor.jar".  On Linux, you can find this with "locate exteditor.jar", but you can use any filesystem search tool to find it.

2.  Edit the file "exteditor.xul" in this java archive.  I used emacs, which can open and edit jar'ed files directly from the archive, but you may have to extract the archive (with "jar xf"), edit the file, and rearchive the files (with "jar uf") when you are done.

3. Inside exteditor.xul, there is a <keyset> ... </keyset> block that defines the hotkey.  To disable it (which is what I did), just delete or comment out this block (put it in XML comment tags: <!--  -->).  You can probably also change it to another key by changing the "E".

4. After saving (and possibly rearchiving) the exteditor.jar file, restart Thunderbird, and the new behavior should take effect.

Please note:  your changes may be overwritten if the extension gets updated.  But, hopefully, the author will make this configurable so we don't have to keep changing it.  Good luck!
  Poster une réponse  Haut
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message   -   Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter
[]
Catégories de discussion  Forum 



^ Haut ^