Don
Faire un don pour aider au developpement de WiPhA

Recherche




Préférences

Se reconnecter
---

Votre nom (ou pseudo) :

Votre code secret


 Nombre de membres 126 membres


Connectés :

( personne )
Visites

 2949600 visiteurs

 12 visiteurs en ligne

forum.gifForum - Web iPhoto Access - Sujet n°343

Forum - Forum
Web iPhoto Access - Web iPhoto Access


actif  Sujet n° 343  Wipha with https

le 05/01/2013 @ 00:39
par guigui

Anonyme

visiteur

Hello,
I've installed wipha successfully on a ubuntu server with a local mirror of my iPhoto library.
I use as a webserver apache2 configured to use https by default.
Everything works great except login and logout which tend to redirect to the server address with http and not https. Modifying the address in the browser bar works fine, but that can only be a temporary solution.
Any idea of what part of main.php or other file I should modify?
Thanks a lot for your answer and keep up the good work!
  Poster une réponse  Haut
Réponse n° 1
--------
le 05/01/2013 @ 00:54
par Guigui

Anonyme

visiteur
OK, replying to myself...
It's a bit dirty but I found a solution. so if anyone is interested, do the following :edit the utils.php file in libs folder and replace all occurrences of http:// by https://
don't replace this section, it contains external link that are not impacted by the problem :function cssValidUrl() {    $val = "http://jigsaw.w3.org/css-validator/validator?uri=";    return validUrl($val);
}

//----------------------------------------------
function xhtmlValidUrl($libId) {    $val = "http://validator.w3.org/check?uri=";    return validUrl($val, $libId);
}

Cheers
  Poster une réponse  Haut
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message   -   Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter
[]
Catégories de discussion  Forum 



^ Haut ^