Don
Faire un don pour aider au developpement de WiPhA

Recherche




Préférences

Se reconnecter
---

Votre nom (ou pseudo) :

Votre code secret


 Nombre de membres 123 membres


Connectés :

( personne )
Visites

 2178833 visiteurs

 12 visiteurs en ligne

forum.gifForum - External Editor - Sujet n°361

Forum - Forum
External Editor - External Editor


actif  Sujet n° 361  External Editor not working

le 04/11/2015 @ 15:07
par nurfz

Anonyme

visiteur

This awesome add-on unfortunately does not work in my Thunderbird 38.3.

Whenn I press Ctrl+E (or the menu item) this error shows up in Thunderbird's error console:

Timestamp: 03.11.2015 22:53:34
Error: TypeError: document.getElementById(...) is null
Source File: chrome://exteditor/content/exteditor.js
Line: 442

Can someone help me? Thank you!
  Poster une réponse  Haut

[]   

Réponse n° 1
--------
le 11/01/2016 @ 22:45
par ExternalUser

Anonyme

visiteur
Same problem in Thunderbird 38.5.1 --

Timestamp: 2016-01-11 15:42:03
Error: TypeError: document.getElementById(...) is null
Source File: chrome://exteditor/content/exteditor.js
Line: 442

Unfortunate because this is a great plug in.
  Poster une réponse  Haut
Réponse n° 2
--------
le 13/04/2016 @ 20:02
par yamsu

Anonyme

visiteur
Hi,

The issue is that external editor doesn't work if the compose window is opened for HTML emails. If you go to your email account settings and uncheck "Compose with messages in HTML Format", under Composition & Addressing, extEditor v1.0 will work.

I have successfully tried it on Thunderbird 38.6 and it is working.

I use this with vim, and i can't imagine why thunderbird doesn't have a feature like this inbuilt.

Hope you guys can get it to work.
  Poster une réponse  Haut
Réponse n° 3
--------
le 15/04/2016 @ 07:07
par jakob

Anonyme

visiteur
For me, the problem was that I removed (hid) the plug-ins' "edit in external editor" button in the message compose window.

I removed the button because I wanted to use the shortcut Ctrl+E only. But this raises an JS Exception in the plug-ins' source code, because it cannot find the button.

So my solution: Click customize on the compose window's toolbar and restore the ExternalEditor button.
  Poster une réponse  Haut
Réponse n° 4
--------
le 08/02/2017 @ 06:18
par guido

Anonyme

visiteur
Just a quick note: it works like a charm also in my xubuntu 16.10 Linux box. The only problem is that firefox complains about the plugin, and even refuses to download it: using chrome/chromium it's all right.

Thank you. Great plugin, simple and effective solution.
Ecrire à guido   Poster une réponse  Haut
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message   -   Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter
[]
Catégories de discussion  Forum 



^ Haut ^