Don
Faire un don pour aider au developpement de WiPhA

Recherche




Préférences

Se reconnecter
---

Votre nom (ou pseudo) :

Votre code secret


 Nombre de membres 126 membres


Connectés :

( personne )
Visites

 2318767 visiteurs

 25 visiteurs en ligne

forum.gifForum - External Editor - Sujet n°136

Forum - Forum
External Editor - External Editor


clos par Globs le 22/08/2007 @ 17:14  Sujet n° 136  Quoting problem

le 12/09/2006 @ 11:15
par Per

Anonyme

visiteur

Many thanks for this extension, finally makes a GUI mail client usable for me!e (I use it with 'emacsclient' as the external editor, works perfectly.)

There is one annoyance though, and it probably isn't something that can be fixed by the extension but rather needs to be addressed in TB itself: When you edit a reply (even without actually changing anything), the leading quote characters ('>') lose their magic property (e.g. being shown as colored bars by TB) and become part of the text.

When actually sending the message, there is a space prepended to them, but this isn't shown either in TB or the external editor, so can't even be "fixed manually". The result is of course that the recipient will also see "plain text" quote marks, plus wastage
of a character column and general messiness when there are multiple levels of quotes.

The same thing happens if you paste "quoted" text into TB's own editor (this is the method I ususally use with GUI "editors"e, which is why I assume that it's TB that is the "real" problem. Anyway, if anyone knows how to avoid this problem when using the external editor, I would love to find out!

--Per
Ecrire à Per  sujet clos  Haut
Réponse n° 1
--------
le 30/03/2007 @ 23:19
par aiyagari

Anonyme

visiteur
One workaround for this is to do "Edit/Rewrap."  You can even do it on a selected section and the magic property comes back -- but -- it rewraps the text, so usually stuff gets messed up unless it was already in paragraphs.  Therefore, there must be some API that Rewrap is calling that restores the magic.  If this extension could call that same API, then maybe it could restore the magic property without actually rewrapping.
  clos par Globs le 22/08/2007 @ 17:14  Haut
Réponse n° 2
--------
le 03/05/2007 @ 18:56
par Per

Anonyme

visiteur
Thanks a lot - I would probably use this workaround, except I came back here (after many futile checks for responsessmile to record that I found a solution that works even better for me at least: Disable sending of "format=flowed" (which I don't care for anyway) by adding:

user_pref("mailnews.send_plaintext_flowed", false);

to prefs.js (see e.g. http://kb.mozillazine.org/Plain_text_e-mail_-_Thunderbird)

The format=flowed spec calls for the MUA to distinguish between quoted lines and lines that "just happen" to start with '>', and apparently when the text is sent through the external editor, lines are
transformed from the former to the latter...

Ecrire à Per   clos par Globs le 22/08/2007 @ 17:14  Haut
Réponse n° 3
--------
le 03/05/2007 @ 20:57
par Globs

Globs

Administrateur

Thanks for this information. That's where I appréciate a forum, compared to private mails sent to the author.

Edit: issue solved. See topic #226
Ecrire à Globs   Site web Globs clos par Globs le 22/08/2007 @ 17:14  Haut
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message   -   Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter
[]
Catégories de discussion  Forum 



^ Haut ^