Thunderbird Extensions
Apple - mac
Web iPhoto Access
Donation
Make a donation to help WiPhA development

Search




Preferences

 Count of members 29 members


Users online

( nobody )
Visits

 147732 visitors

 15 visitors online

Private
Post an answer

Thanks for taking the time to write this message.

 

Your name :

Your e-mail :

Hide your e-mail address to visitors:      

Note: the e-mail address used is protected against SPAM.

 

To receive mail notification of a reply :      

You answer to Preston who has written:


OK, I too want to install on OS X Server.

I read through the included script in the install. Basically, my server was already setup for PHP, and .htaccess files.

These were set in:

/etc/httpd/httpd.conf
and
/etc/httpd/site/000_any_80_yourdomain.com.conf

files respectfully

So I went through changed all the permissions (see note about changeperm below)

But there is some problem with PHP and redirects

When you first connect (either as admin or guest) it does not bring you to the view screen, but leaves you at the login screen. (there is one entry of main.php?guest)

Clicking reload you get the "library loading" status, but when it reaches %100 it just flickers and acts like its reloading the page (though the server only shows one entry of main.php in the log. If you click refresh AGAIN, another entry of main.php shows in the log, and the "display" page now shows normally and WIPHA works just fine.

The same browser/client works just fine with WIPHA served from OSX-client, but breaks with OSX-server (so its not just in the client). The problem exists with Firefox and Safari.

So its something with PHP/Apache and redirects on OSX-server, because on my OSX-client install, when the "Guest" link is clicked, I see three entries in the log:

main.php?guest
main.php
main.php

So the browser is reloading the page properly.

You would sure think this is a client issue in the browser, not the server.

Also, for OSX-server installations, it would be nice to disable the changeperm utility and rely on Tiger's ACL's to ensure that the user 'www' has permission on the iPhoto libraries. (no umask headache).

Any idea of settings to change in the server? My phpinfo is:

http://www.sanroque.net/temp.php

-Preston

Your answer :

bold text  italic text  underlined text  pre formated text  text color  center text  insert a link  undo  redo  Quote 
|:-) ;-) :-)) :-) :-o :o) :-(( :-( 8-) :-p ;-(  Help


 
^ Top ^

GuppY - http://www.freeguppy.org/    Site powered by GuppY v4.5.14 2004-2005 - CeCILL Free License   GuppY - http://www.freeguppy.org/

Document generated in 0.07 second