Donation
Make a donation to help WiPhA development

Search




Preferences

Connect again
---

Your name (or pseudo) :

Your secret code (associated with your pseudo)


 Count of members 45 members


Connected :

(nobody)
Visits

 331366 visitors

 14 visitors online

Private
forum.gifForum - Web iPhoto Access - Topic #44

Forum - Forum
Web iPhoto Access - Web iPhoto Access
- Topic # 44


active Topic # 44  Problem at installation

28/01/2006 @ 04:39
by Sweetsounds

Anonymous

visitor

I followed the instructions to the letter, but when I try to access the server, I get to a page that says "Forbidden
You don't have permission to access /~renlapal/wipha/ on this server.
Apache/1.3.33 Server at ordinateur-de-ren-lapalme.local Port 80"

I really followed the instructions exactly (used the installer, turned on the web server...). What could be causing this. Please help !
  Post an answer  Top

[]   

Start Previous one [ 1 2 ] Next one End
Answer n 1
--------
28/01/2006 @ 14:29
by kaz

Anonymous

visitor
Same here... Any solution so far?
  Post an answer  Top
Answer n 2
--------
28/01/2006 @ 14:35
by kaz

Anonymous

visitor
SOLUTION:
http://www.oreillynet.com/cs/user/view/cs_msg/11982
"other" must have the permission "read only" for your home directory and your "Sites" directory. (command-i to see the permissions of a directory)
  Post an answer  Top
Answer n 3
--------
28/01/2006 @ 17:42
by Sweetsounds

Anonymous

visitor
That was already the case... so that's not the problem. My permissions were, and are still, exactly as you say, but I still can't access the site. Any other ideas ?
  Post an answer  Top
Answer n 4
--------
28/01/2006 @ 17:51
by Globs

Globs

Administrator

I don't now if this has a connection but could you try the complete URL ending with index.php:

http://yourIP/~userName/wipha/index.php


Write to Globs   Web site Globs Post an answer  Top
Answer n 5
--------
28/01/2006 @ 17:59
by Sweetsounds

Anonymous

visitor
Well, that go me further : I saw the login page. smileHowever, after I typed admin/admin, I got to a page with this message : Could not open file data/users.ser for writing, at Persistent::save

Argh !
  Post an answer  Top
Answer n 6
--------
28/01/2006 @ 18:04
by Globs

Globs

Administrator

Are you sure that your install worked wine ? no error message ?
The permission of your data folder must be: drwxrwsrwt

If they are, 'www' user must be able to write in it.

Write to Globs   Web site Globs Post an answer  Top
Answer n 7
--------
28/01/2006 @ 18:20
by Sweetsounds

Anonymous

visitor
Everything had worked fine... But just in case, I reinstalled. Everything seems to be working, now. Phew ! But yeah, I have to add index.php at the end of the URL for it work. Is that normal ?
  Post an answer  Top
Answer n 8
--------
28/01/2006 @ 18:29
by kaz

Anonymous

visitor
ok, my problem now is that it doesn't choose automatically the index.php. And when I click on index.php, it just open it as a text file: I see the code, that's all.


I restarted my computer, re-installed wipha, restarted the web server, but nothing changed...
  Post an answer  Top
Answer n 9
--------
28/01/2006 @ 19:01
by Globs

Globs

Administrator

@Sweetsounds:

No, it's not normal. It depends on your browser and on the server settings. With the 10.4.x settings (which afaik I didn't change in that behaviour), both Firefox and Safari don't require to append index.php. IE does. But would do *you* need it, I don't know. Not a big deal after all if everything else works.

@kaz:

I suppose you had a problem with your installation process and php has not been enabled.
These 2 lines in /etc/httpd/httpd.conf must not be commented anymore (must not begin with #):

LoadModule php4_module        libexec/httpd/libphp4.so
AddModule mod_php4.c



Could both of you send me this file to see if there is any difference with mine.
Although this has probably nothing to do with the issue, please also check in /etc/httpd/users. There must be a <your_name>.conf file containing this:

<Directory "/Users/your_name/Sites/">
    Options Indexes MultiViews
    AllowOverride All
    Order allow,deny
    Allow from all
</Directory>


Write to Globs   Web site Globs Post an answer  Top
Answer n 10
--------
28/01/2006 @ 19:33
by kaz

Anonymous

visitor
You were right. Teh two lines were commented in the httpd.conf file, and in the <my_name.conf> file was written "AllowOverride none"...

I succeeded to load the login page. After logging in as admin, I have:
Warning: is_file(): Stat failed for ipl/AlbumData.xml (errno=13 - Permission denied) in /Users/cyprien/Sites/wipha/libs/wipha.php on line 119
Can't find iPhoto file ipl/AlbumData.xml

My AlbumData.xml file is in /Users/myName/Pictures/iPhoto Library/
  Post an answer  Top
Answer n 11
--------
28/01/2006 @ 19:45
by Globs

Globs

Administrator

kaz,
it's clear here that the installer did not perform the operations requiring to get admin priviledge.
The question is, why???
Maybe you should try to investigate why this happened, rather that redoing all the install manually?

Have you been prompted for an admin login when installing ?
Did you give it properly ?
Did the installer not display any error until it tells you to start the web server ?


As an alternative, you may enter in the installer directory from the terminal and sudo the install script ? (it expects one parameter: the absolute path of the installer application directory (the .app dir))
I did not try it but it should work.

Write to Globs   Web site Globs Post an answer  Top
Answer n 12
--------
28/01/2006 @ 19:54
by kaz

Anonymous

visitor
I agree with you, it would be smarte to find out why the installation went wrong, instead of re-inventing the wheel.

I made a reinstallation, I was asked for my admin password, and the text displayed didn't mentionned any error. At the end was written "installation complete" and "you have to start/restart your web sharing".

What's strange, is that now I can't anymore get the login page. Only the error message I already mentionned...
  Post an answer  Top
Answer n 13
--------
28/01/2006 @ 19:59
by Globs

Globs

Administrator

Yes, but I'm afraid you're on your own for that, I don't really see how I could investigate this.

check error messages on the console, try, as I wrote, to direclty sudo the script, check the result of any operation....
Write to Globs   Web site Globs Post an answer  Top
Answer n 14
--------
30/01/2006 @ 11:33
by kaz

Anonymous

visitor

I tried to execute the script directly:
----------------------------------------------------------------------
/Users/myName/Desktop/WiPha/Wipha\ Installer.app/Contents/MacOS/Web\ iPhoto\ Access\ Installer /Users/myName/Desktop/WiPha/Wipha\ Installer.app
----------------------------------------------------------------------

It ask for my admin password and then give me this:
----------------------------------------------------------------------
Saving previous wipha preferences
cp: /Users/cyprien/Sites/wipha/data/users.ser: No such file or directory
... Abort ...
----------------------------------------------------------------------

I then removed the WiPha directory in the Sites directory. It became a bit better, I had the following in the WiPhA window:
----------------------------------------------------------------------
Decompacting WiPhA in your Sites folder (/Users/cyprien/Sites)

Setting permissions on these files

Setting setuid bit (cyprien) on permission corrector executable

Authorize Apache to go through your Pictures folder

Grant write access to Apache on the WiPhA data directory

Configuring Apache to handle php
    Was already done

Configuring Apache to use local .htaccess for user cyprien
    Was already done

Installation complete

Start (or restart) the Web server as explained in the documentation, and type the following URL in your web browser to go to WiPhA
http://localhost/~cyprien/wipha
-----------------------------------------------------------------

But in the terminal - which might interest you - I had this:
----------------------------------------------------------------------
/Users/myname/Desktop/WiPha/WiPha Installer.app/Contents/Resources/script: line 90: [: !=: unary operator expected
/Users/myname/Desktop/WiPha/WiPha Installer.app/Contents/Resources/script: line 108: [: !=: unary operator expected
/Users/myname/Desktop/WiPha/WiPha Installer.app/Contents/Resources/script: line 138: unexpected EOF while looking for matching `"'
/Users/myname/Desktop/WiPha/WiPha Installer.app/Contents/Resources/script: line 139: syntax error: unexpected end of file
----------------------------------------------------------------------

So it seems like there are some "hidden" errors here. I took a look at the script, and it seems that it doesn't like every time you use "" (2 quotation symbols consecutively)


  Post an answer  Top
Answer n 15
--------
30/01/2006 @ 11:38
by Globs

Globs

Administrator

Thank's for this test. I'll try to understand and correct this asap.
Write to Globs   Web site Globs Post an answer  Top
Answer n 16
--------
31/01/2006 @ 11:42
by Globs

Globs

Administrator

So, the first 2 errors happened when the config was already ok, so it did not explain why the install could go wrong. I corrected them.
The last 2 errors were just caused by a missing quote at the end of the last sentence of the "install complete..." message.

I'm now going to add some checks that the changes I tried to perform have actually been taken in account.
Write to Globs   Web site Globs Post an answer  Top
Answer n 17
--------
31/01/2006 @ 13:43
by kaz

Anonymous

visitor
Thanks a lot!
  Post an answer  Top
Answer n 18
--------
31/01/2006 @ 20:10
by Globs

Globs

Administrator

Hi again kaz,
I delivered the 0.7 version. Hoping the checks I added will either fix your issue or show you where it is.
Please let me know...
Write to Globs   Web site Globs Post an answer  Top
Answer n 19
--------
01/02/2006 @ 12:32
by kaz

Anonymous

visitor
It works!! Thanks a lot for your help!

Only detail: chmod -R o+x wasn't enough for me. I had to make a chmod -R o+rx /Users/shortname/Pictures

But I'm thus granting the rights to read all my iPhotos to anybody connecting through ssh to my computer. Is it normal? What should be the permissions (can you write it like "rwxrwxrwx", so there's no confusion), respectively from my home folder, my Pictures folder, my iPhoto Library folder, and all the files *in* the iPhoto Library.

Thanks a lot again!
  Post an answer  Top
Answer n 20
--------
01/02/2006 @ 14:00
by Globs

Globs

Administrator

Hi,
glad to know it finally works smile

Permissions:
I will just write the rwx for others, as it's the only one which impacts wipha. You can have anything you want for the user and group permission bits.
I write '?' when it may be on or off.

home: ??x
Sites/wipha: r?x
Pictures: ??x
Pictures/iPhoto Library and all subfolders: ??x
AlbumData.xml and all image files: r?-

You should remove r perm on directories (so you can't list them). You just need x perm, so you can go through them. And you need r perm on files.

So, yes, you grant access to anybody logged on your machine to your photos, if they know the exact path to them, which is possible if they open AlbumData.xml and search for the pathes.
The only way to avoid this is to have apache running as yourself, but  this seems worse imho.

Normally, if changeperm has the good permission, it will automatically, each time you tries to connect to wipha, do the chmod o+x on Pictures, iPhoto Library and subfolders, and chmod o+r on AlbumData.xml and image files.

Write to Globs   Web site Globs Post an answer  Top
Start Previous one [ 1 2 ] Next one End
active topic active   closed topic closed   Sticky Sticky   New New message   -   Correct Correct message   Close Close topic   Make sticky Make sticky
[]
Forum Topic  Forum 


^ Top ^