Thunderbird Extensions
Apple - mac
Make a donation to help WiPhA development



Connect again

Your user name :

Your secret code

 Count of members 123 members

Connected :


 2073859 visitors

 11 visitors online

forum.gifForum - External Editor - Topic #353

Forum - Forum
External Editor - External Editor

active  Topic # 353  Empty file opened in Maverick and Thunderbird 24

07/11/2013 @ 18:22
by rkrug



I am using Thunderbird 24.1.0 on Maverick, and try to use emacs as my externl editor.
My problem is that Thunderbird, upon calling "external editor", does not seem to save the email, as in emacs an empty file is opened (with the name SUBJECT_alongnumber.eml in the folder /tmp/).
This is now always happening, after initially it worked once.
I have write access to this folder, so it is not a problem from this side.
I am using it on a Macbook Pro Retina, and haven't tried it before the upgrade (was using GNUS then).
Any ideas what is happening?
  Post an answer  Top


Answer n 1
10/12/2013 @ 17:11
by rkrug


OK - I solved it. One has to use the -W option when specifying the editor and using the open command. From the manual of open:

-W  Causes open to wait until the applications it opens (or that were already open) have exited.

I now have:

open -W -a Emacs --args -Q

and it works nicely.

  Post an answer  Top
Answer n 2
13/03/2014 @ 22:01
by Saibot


I have a similar problem: my editor opens an empty file, which is consistent with the fact that Thunderbird does not create any file in /tmp before the editor is called. Moreover, when I use my editor to compose a message, save, and quit, no content appears in Thunderbird.

Any ideas? I don't think that the previous user's solution is applicable to me since I don't use "open" or even know what it is.

I am on Gentoo Linux with Thunderbird 24.3. External Editor calls this script to fire vim:

urxvtc -e zsh -c "vim $@"

I also use this for Firefox with the analogous "It's all Text" extension and it works perfectly.

Thanks for any hints!
Write to Saibot   Post an answer  Top
Answer n 3
16/03/2014 @ 00:05
by globs


I know nothing about urxvtc, but a small search found the following:

"Currently, it always returns immediately after contacting the daemon."

Which is consistent with the fact you find no file in /tmp. It is deleted immediateley after urxvtc returns.

Now, I don't explain how this works with IAT in Firefox s
Write to globs   Post an answer  Top
Answer n 4
03/04/2014 @ 00:51
by saibot


Thanks, globs! Not calling the daemon for requesting a new terminal indeed did the trick. So this is my new script:

urxvt -e zsh -c "/usr/bin/vim $@"

Now I can finally compose emails in my favorite editor l
  Post an answer  Top
Answer n 5
16/06/2014 @ 10:27
by Grateful


Hallelujah!  Thanks so much rkrug.

Before: dkd

After: l
  Post an answer  Top
active topic active   closed topic closed   Sticky Sticky   New New message   -   Correct Correct message   Close Close topic   Make sticky Make sticky
Forum Topic  Forum 

^ Top ^