Thunderbird Extensions
Apple - mac
Donation
Make a donation to help WiPhA development

Search




Preferences

Connect again
---

Your user name :

Your secret code


 Count of members 123 members


Connected :

(nobody)
Visits

 2073897 visitors

 22 visitors online

Private
forum.gifForum - External Editor - Topic #361

Forum - Forum
External Editor - External Editor


active  Topic # 361  External Editor not working

04/11/2015 @ 15:07
by nurfz

Anonymous

visitor

This awesome add-on unfortunately does not work in my Thunderbird 38.3.

Whenn I press Ctrl+E (or the menu item) this error shows up in Thunderbird's error console:

Timestamp: 03.11.2015 22:53:34
Error: TypeError: document.getElementById(...) is null
Source File: chrome://exteditor/content/exteditor.js
Line: 442

Can someone help me? Thank you!
  Post an answer  Top
Answer n 1
--------
11/01/2016 @ 22:45
by ExternalUser

Anonymous

visitor
Same problem in Thunderbird 38.5.1 --

Timestamp: 2016-01-11 15:42:03
Error: TypeError: document.getElementById(...) is null
Source File: chrome://exteditor/content/exteditor.js
Line: 442

Unfortunate because this is a great plug in.
  Post an answer  Top
Answer n 2
--------
13/04/2016 @ 20:02
by yamsu

Anonymous

visitor
Hi,

The issue is that external editor doesn't work if the compose window is opened for HTML emails. If you go to your email account settings and uncheck "Compose with messages in HTML Format", under Composition & Addressing, extEditor v1.0 will work.

I have successfully tried it on Thunderbird 38.6 and it is working.

I use this with vim, and i can't imagine why thunderbird doesn't have a feature like this inbuilt.

Hope you guys can get it to work.
  Post an answer  Top
Answer n 3
--------
15/04/2016 @ 07:07
by jakob

Anonymous

visitor
For me, the problem was that I removed (hid) the plug-ins' "edit in external editor" button in the message compose window.

I removed the button because I wanted to use the shortcut Ctrl+E only. But this raises an JS Exception in the plug-ins' source code, because it cannot find the button.

So my solution: Click customize on the compose window's toolbar and restore the ExternalEditor button.
  Post an answer  Top
active topic active   closed topic closed   Sticky Sticky   New New message   -   Correct Correct message   Close Close topic   Make sticky Make sticky
[]
Forum Topic  Forum 



^ Top ^