Thunderbird Extensions
Apple - mac
Web iPhoto Access
Make a donation to help WiPhA development



 Count of members 29 members

Users online

( nobody )

 147698 visitors

 8 visitors online

forum.gifForum - Web iPhoto Access - Topic #53

Topic #53 Can't view fullsize (some anyway)
    by Willy - visitor
02/02/2006 @ 04:24
Ok so installation didn't work initially, because although my Pictures folder had access (o+x), the iPhoto Library folder didn't.  So I fixed that... Now, I can see all thumbnails.  The first photo I opened fullsize, worked.  AND, I liked that it pulled up my modified (fixed red eye) version.  However, I started clicking on others, and got the "Can't access to the file" error.  I looked via Terminal, and it looks like some directories under Originals don't have the x bit set for permissions, and some do.  Same inconsistency for files underneath.  I'm wonder why it's not getting applied to all.  FWIW, I'm going down the route now of just using ACL controls to let the 'www' user have full access, but I'd like to know it works out of the box to set it up on my wife's account.
Post an answer

Answer #1 by Globs - rank ( 115 messages )
02/02/2006 @ 12:34

Strange. The changeperm program is supposed to fix all these perm when you connect to wipha.
All wipha is supposed to check that changeperm has enough rights to do the job.
Have a look in the httpd error log to see if changeperm fails for some reason...

Site web Globs Write to Globs Post an answer


Answer #2 by Willy - visitor
09/02/2006 @ 02:57
I finally got around to looking the logs.  It generated a bunch of "No such file or directory" errors, because it looked like it choked on album folders that had spaces or punctuation.  i.e. I have an album (directory in the filesystem) called "Family Portrait", and in the apache logs I see (basically):

stat "Family": File not found
stat "Portrait": File not found

Write to Willy Post an answer


Answer #3 by Globs - rank ( 124 messages )
09/02/2006 @ 11:22
Strange again smile
changeperm quotes every name because of spaces, and I succesfully changed permissions on albums such like yours in my own library.
I'll try to have a look on this issue.
Maybe you could send by mail the result of this command:

cd /path/to/your/iPhoto Library
find *

and also the complete section of stat errors.


Site web Globs Write to Globs Post an answer


Answer #4 by Globs - rank ( 129 messages )
14/02/2006 @ 12:18
Just for the record:
There was indeed an error in the changeperm method which made it fail for folders containing a single quote character.
This will be solved in the forthcoming 1.0 version.
Site web Globs Write to Globs Post an answer


Answer #5 by hseldon - rank ( 2 messages )
08/10/2006 @ 18:13
hseldon$ cd /Users/hseldon/pictures/iPhoto Library
-bash: cd: /Users/hseldon/pictures/iPhoto: No such file or directory

here is one of my stat lines

stat /users/hseldon/pictures/iphoto library//Users/hseldon/Pictures/iPhoto Library/2006/10/02/Movie.jpg: No such file or directory

this is version 2.2 looks like it really doesn't like the space in the directory name

special knowledge can be a terrible disadvantage if it leads you too far along a path that you cannot explain anymore.

mentat admonition

Write to hseldon Post an answer


Answer #6 by Globs - rank ( 269 messages )
08/10/2006 @ 21:46
bash doesn't work like this.
cd "bla bla bla"
cd bla\ bla\ bla

wipha does support spaces in names. "iPhoto Library" is the standard default name, and is of course supported.
I would rather wonder about letter cap. Try to respect them and look if it works better.
Pictures/iPhoto Library/...
Site web Globs Write to Globs Post an answer


^ Top ^

GuppY -    Site powered by GuppY v4.5.14 2004-2005 - CeCILL Free License   GuppY -

Document generated in 0.07 second