Thunderbird Extensions
Apple - mac
Web iPhoto Access
Make a donation to help WiPhA development



 Count of members 29 members

Users online

( nobody )

 147704 visitors

 8 visitors online

forum.gifForum - Web iPhoto Access - Topic #56

Topic #56 Setup on Server
    by Mack - visitor
06/02/2006 @ 09:03
While trying to log on for the first time as Admin, I am getting the error

Could not open file data/users.ser for writing, at Persistent::save

I had to copy the folder from the installer, install in in the webserver documents folder with the rest of my website, and make an alias of the Iphoto library folder (which is on an external HD) and rename it ipl and put it in the waphi folder.

So I am guessing that some other data files may not have initalized?

Any suggestions?
Post an answer

Answer #1 by Mack - visitor
06/02/2006 @ 09:12
I am very sure it's a permission problem.

Exactly WHAT and HOW do we do that, as the installer will not work on a server setup?

On OSX Server the main website is in the Library/Webserver/Documents folder. And the iphoto library may (and usually) is on an external HD.

Can there be two intstallers? One simple one for personal sites, and another that uses variables that lets us browse to the locations it needs?

Other than that, can you give me a full list of which and what I need to do to fix permissions?
Post an answer


Answer #2 by Globs - rank ( 119 messages )
06/02/2006 @ 14:43

making an installer for an OS I don't own won't be easy. How to validate it ???
Allowing GUI interaction won't be easy either. My installer is a sh script embedded in a simple app bundle.

To fix permissions, plase follow what I indicate in the installation documentation. copy/paste:
  • Authorizing Apache (www) to go through your Pictures folder
    • chmod o+x ~/Pictures
  • Set WiPhA data directories so that Apache (www) can write in them (user logins, thumb cache)
    • chmod 3777 data data/cache (777 + setgid + sticky)
  • Set the setuid bit (with user right, not root!) on a small C program which will chmod o+r or o+x the required iPhoto Library files or directories. This has proved bo be needed for different iPhoto versions which remove these rights on every modification or file creation, whatever your umask is (I hate that).
    For security reason, this program can't modify anything outside of your Pictures folder, and can only be run by you and Apache (www).
    • chmod 4755 changeperm
You'll probably need to delete the ipl symlink in the wipha folder and recreate it properly according to your iPhoto Library location.

Site web Globs Write to Globs Post an answer


Answer #3 by Mack - visitor
07/02/2006 @ 10:05
I went in, not with the linux, but with the mac privledges, and opened all those in the pictures, and wipha to read and write for all.

That solved the login problem, but now it's giving me an error

"wipha/changeperm has not the correct permission. This could prevent you from parsing the database or displaying pictures properly.

Please correct this issue to keep going:

chmod 4755 /Users/<user>/Sites/wipha/changeperm"

but sinced the wipha folder is not in sites, but rather the library/webserver/documents/

I've gone in and given it the 4755 via the terminal program, but I still get this error.
Write to Mack Post an answer


Answer #4 by Globs - rank ( 120 messages )
07/02/2006 @ 12:23

if you do have this changeperm program in the wipha folder with 4755 permission, I don't understand how you can get this error.

Anyway, changeperm won't work for you, as I hardcoded it to work in /Users/<user>/Sites/wipha/ipl (that was a security choice). I'll have to rethink about that.

So you have the option to edit the file wipha/libs/wipha.php and modify the bloc to bypass the test (in the function parseDataFile):

            $­stat = stat('./changeperm');
            if (($­stat['mode']&04555)!=04555) ­{­
                $­this->smarty->assign('error', 'changeperm');
            } else ­{­

You can also remove the call to the correctPermissions function.

You will have to check your AlbumData.xml and new (or corrected) images permissions each time you use iPhoto to make sure by yourself that all files are still readable.

If you trust me, you can also send me by mail your wipha URL and a ssh login so that I can try to understand why you still get this error.

Site web Globs Write to Globs Post an answer


^ Top ^

GuppY -    Site powered by GuppY v4.5.14 2004-2005 - CeCILL Free License   GuppY -

Document generated in 0.05 second