Thunderbird Extensions
Apple - mac
Web iPhoto Access
Donation
Make a donation to help WiPhA development

Search




Preferences

 Count of members 29 members


Users online

( nobody )
Visits

 147705 visitors

 9 visitors online

Private
forum.gifForum - Web iPhoto Access - Topic #72


Topic #72 Warning on admin page
    by Ike - visitor
24/02/2006 @ 06:32
Anonymous
Hi, I managed to install wipha on my 10.4.5 box by
a) adding the three lines (install suggested two)
to the end of my httpd.conf file
<Directory "/Users/isaac/Sites">
AllowOverride All
</Directory>
b) commenting these lines in .htaccess in wipha directory
# Used for PHPs running as cgi rather than apache module
#<IfModule mod_rewrite.c>
# RewriteEngine on
# RewriteRule .* - [E=REMOTE_USER:%{HTTP:Authorization},L]
#</IfModule>

after this I get the following error

Warning: file_get_contents(https://globs.org/update.txt): failed to open stream: Connection refused in /Users/isaac/Sites/wipha/libs/wipha.php on line 94

Does anyone have an idea what's up?
Thanks in advance.
Post an answer




Answer #1 by Globs - rank ( 154 messages )
24/02/2006 @ 13:46
Globs
This is where Apache tries to connect to my site to check for an update version.
You probably have a firewall or little snitch or something which prevents it to open this connection.
Site web Globs Write to Globs Post an answer

Top

Answer #2 by Globs - rank ( 155 messages )
24/02/2006 @ 13:49
Globs

Dixit...
a) adding the three lines (install suggested two)
to the end of my httpd.conf file
<Directory "/Users/isaac/Sites">
AllowOverride All
</Directory>


I don't understand why you need this, since httpd included user conf files.
the installer is supposed to update (or create if necessary) your /etc/httpd/users/you.conf with this setting.
Site web Globs Write to Globs Post an answer

Top

Answer #3 by ike - visitor
25/02/2006 @ 11:27
Anonymous
You asked:
don't understand why you need this, since httpd included user conf files.
the installer is supposed to update (or create if necessary) your /etc/httpd/users/you.conf with this setting.

Your install program suggested I do this! Without it, nothing worked, so I did it and at least I got the site.
Post an answer

Top

Answer #4 by ike - visitor
25/02/2006 @ 11:30
Anonymous
I am not running little snitch, so unless you are trying to get
out on a non standard port number, I'm not sure I understand
why version checking should be a problem. Plenty of apps I use do version checking.

I assumed it was a problem, as when I logged in as admin it didn't even seem to find the standard iphoto library, which
I assumed it would by default. Perhaps it doesn't by default.
Post an answer

Top

Answer #5 by Globs - rank ( 158 messages )
25/02/2006 @ 16:38
Globs

Dixit...
unless you are trying to get out on a non standard port number, I'm not sure I understand why version checking should be a problem


Neither do I. I just use the file_get_contents standard php function to get this info, so it surely use the standard port.
You can use this simple php page to test it:
<?php
echo file_get_contents("https://globs.org/update.txt");
?>
It should display such a string:

a:1:­{­s:5:"wipha";a:2:­{­s:3:"ver";s:3:"2.0";s:3:"dat";s:11:"22 Feb 2006";}}


There is no iphoto library set by default. You need to add them, as I explain in the doc.
Site web Globs Write to Globs Post an answer

Top

^ Top ^

GuppY - http://www.freeguppy.org/    Site powered by GuppY v4.5.14 2004-2005 - CeCILL Free License   GuppY - http://www.freeguppy.org/

Document generated in 0.05 second