Thunderbird Extensions
Apple - mac
Web iPhoto Access
Donation
Make a donation to help WiPhA development

Search




Preferences

 Count of members 29 members


Users online

( nobody )
Visits

 147705 visitors

 9 visitors online

Private
forum.gifForum - Web iPhoto Access - Topic #80


Topic #80 Wipha on Filevault account?
    by mitchcohen - visitor
11/03/2006 @ 16:47
Anonymous
I've installed Wipha on my powerbook. I use Filevault for my account for security.

I'm unable to set a path to access the library. In the Terminal, a pwd shows:

~/Pictures/iPhoto Library

instead of the usual /Users/myname...

I'm quite sure I'd need to be logged in for others to have access to my photos, which is fine.

I also needed to change permissions on my home directory as shown here:

<http://dunck.us/anabasis/archives/2006/02/14/web-sharing-apache-httpd-error-403-on-mac-os-x-while-using-filevault/>

before I could even access any of my Sites files (unrelated to wipha but possibly helpful to others).

Thanks!
Post an answer



Answer #1 by Globs - rank ( 168 messages )
11/03/2006 @ 20:42
Globs
In the terminal, ~ means 'your home', i.e. '/Users/myname'.

I don't know how filevault works, and if you need to be logged in for your home to be readable. That would be logical though.

And yes, you need obviously to set your home and Sites folder o+x if they aren't. Again, I don't know if Filevault changes this, but the default OSX setting is to let them o+rx.

Site web Globs Write to Globs Post an answer

Top

Answer #2 by mitchcohen - visitor
12/03/2006 @ 04:16
Anonymous
Yes, familiar with Unix naming.

Currently in my setup I have this as my path:

/Users/myshortname/Pictures/iPhoto Library/

but when I try to use it I get this message:

Can't access to the iPhoto library data file. Possible causes:

The absolute path you set in the library configuration is wrong
OS Permissions settings prevents Apache (www) to reach some of your files, altough changeperm tried to set them properly
Please correct this issue to keep going...

Filevault is probably the issue - it keeps your home folder in an encrypted disk image on the drive, and mounts it when that user logs in. Good tech info is at:

http://www.macdevcenter.com/pub/a/mac/2003/12/19/filevault.html

Post an answer

Top

Answer #3 by Globs - rank ( 169 messages )
12/03/2006 @ 12:46
Globs
Some ways to troubleshot this:

1/ Check that all directories up to the iPhoto Library are chmod o+x, and that AlbumData.xml is chmod o+r.

2/ Create a new user, activate 'fast user switching' if necessary, and switch to it. Now, try to access the AlbumData.xml. If this works, WiPhA should work too.


Dixit...
As F.J. notes in his article, Filefault mounts a disk image for your home directory, this means that your home directory is not longer truly located at Users/username but is instead a volume mounted at that directory. You can see this using two accounts and fast user switching. Log into the account with Filevault on and switch to a second account, you will see a link in the Users folder for the account with FileVault. Then switch back and log out of the filevault account. Then from the second account, you will see a folder in the User's folder with the disk image in it.



3/ Filevault mounts your home in /Volumes and adds a symlink to it in /Users. If this link is a problem (but I can't imagine why), try setting in WiPhA the real path to your lib: /Volumes/.../iPhoto Library

Or maybe, the issue is not related to FileVault eek ??
Site web Globs Write to Globs Post an answer

Top

^ Top ^

GuppY - http://www.freeguppy.org/    Site powered by GuppY v4.5.14 2004-2005 - CeCILL Free License   GuppY - http://www.freeguppy.org/

Document generated in 0.06 second