Thunderbird Extensions
Apple - mac
Web iPhoto Access
Donation
Make a donation to help WiPhA development

Search




Preferences

 Count of members 29 members


Users online

( nobody )
Visits

 147709 visitors

 11 visitors online

Private
forum.gifForum - Yamb - Topic #8


Topic #8 This folder is being processed...
    by Toby - visitor
16/09/2005 @ 22:25
Anonymous
Hi,

I always get the error message "This folder is being processed. Please wait until processing is complete to get messages." using Yamb.
It has been on Tb 1.0.x and it still is the same on 1.5b1.
Does anyone have the same problems?
The interval of fetching mail is the same than it has been before. Does it make a difference if  I use SSL?

Toby
Post an answer




Answer #1 by Globs - rank ( 14 messages )
17/09/2005 @ 00:36
Globs
Strange confused

I can imagine 2 explanations:
  • Your check interval is too short, and you have too many folders with too many new mails, so that it doesn't have the time to retrieve them all before yamb tries to launch another check.
  • A problem with the junk analysis. Try to uncheck the yamb option "Don't notify junk mail".
Other than that, I have no idea...


Site web Globs Write to Globs Post an answer

Top

Answer #2 by Toby - visitor
17/09/2005 @ 08:32
Anonymous
  • It's not the first reason. The interval is the same as before: it used to be 2 minutes, now it's 120 seconds.
  • And it's not the second reason: just to give it a try a disabled any notification and it's still the same error message.

It does not occur if I  check emails manually, just for the automatic check every two minutes.

There are 4 accounts being checked, the message occurs two times each interval.
 
Post an answer

Top

Answer #3 by TheLod - visitor
21/09/2005 @ 17:27
Anonymous
I have exactly the same problem, 4 account checked with 300second of intervall and the same message, so for me this extension doesn't work cry
Post an answer

Top

Answer #4 by Globs - rank ( 15 messages )
21/09/2005 @ 18:51
Globs
In fact, I've never had the opportunity to test it with so many accounts. I currently use it with a movemail account and rss feeds, but no pop account.
Could you please try to create a new profile in which you could just have one of your accounts and see if it works ?
Then, try an other of your accounts... then test with 2 of them...and so on... to determine when/how it begins to freeze.
I don't see many way to investigateconfused
Site web Globs Write to Globs Post an answer

Top

Answer #5 by Toby - visitor
22/09/2005 @ 08:24
Anonymous
It never happened with one account.
With two accounts it just happened if there where emails online: no emails at startup I did not get the error until the first email was received. (This is not official, just 10min testing).
I also tried with different intervals: like 10 seconds for on account, 11 seconds for the other - this way it would take 11 intervals until the two accounts get mail in the same second. But this did not help.
Write to Toby Post an answer

Top

Answer #6 by Globs - rank ( 16 messages )
23/09/2005 @ 23:59
Globs
I just set 3 pop accounts and I get the error now, so I'll have the mean to debug this. Hold on...
Site web Globs Write to Globs Post an answer

Top

Answer #7 by Globs - rank ( 20 messages )
24/09/2005 @ 03:58
Globs
For now, I can't find any solution to avoid the bug in the extension. I asked for help on usenet...

Though, I can suggest a workaround: I suppose this only happens if you use the Global Inbox. If you change this setting and use a distinct inbox folder for each account, you should not have any problem.

Toby, the 1 second gap between your checks (10s and 11s) was probably too small: I tried 5s, 11s, and 17s with my 3 accounts, and it looked to work. But I only posted a single small message. If the downloading time of one account is longer than 6s, I guess I'm KO again.
Site web Globs Write to Globs Post an answer

Top

Answer #8 by Toby - visitor
24/09/2005 @ 12:12
Anonymous
Hi Globs,

I just set 3 pop accounts and I get the error now, so I'll have the mean to debug this. Hold on...

Thanks for all your work!
For now, I can't find any solution to avoid the bug in the extension. I asked for help on usenet...

Though, I can suggest a workaround: I suppose this only happens if you use the Global Inbox. If you change this setting and use a distinct inbox folder for each account, you should not have any problem.
Thanks but this is not a possibility for me since 6 different account are no fun.
Toby, the 1 second gap between your checks (10s and 11s) was probably too small: I tried 5s, 11s, and 17s with my 3 accounts, and it looked to work. But I only posted a single small message. If the downloading time of one account is longer than 6s, I guess I'm KO again.
Your right, but again. This does not really work. Especially since this way I cannot prevent it from happening for a very long time. Let's say its 17sec and 23sec (which is pretty good already because this are prime numbers) I'll get the error again every 6,5min (or even earlier since the intervals get to close).
Or let us say I put it to 127 and 137 (since I usually get mail every two minutes) it is still every 5h.
And this is only for two accounts - using 6 accounts it's getting more and more difficult.

Thanks though for suggesting!


Toby
Post an answer

Top

Answer #9 by Globs - rank ( 21 messages )
25/09/2005 @ 02:33
Globs
I think I finaly made it ! eek

This is how it works:
For accounts whose inbox folder is used by more than one account, I don't launch the async getmail request anymore.
Rather, I use a function which checks them in a synchroneous way. This function is called at a rate which is set according to the smallest check interval of the concerned accounts.
If some of the accounts to be checked have a larger interval, they are skipped.
For these accounts, this implies that the actual intervals may not exactly respect the requested intervals, as they will be multiples of the smallest interval.
(Not sure to be very clear...)

Anyway, here is a beta version I would like you to test before I release it. Hope it will work for you. If it doesn't, I think I just have to frown

EDIT: The 0.6.4 beta has become the final 0.6.4 and the link has been disabled.
Site web Globs Write to Globs Post an answer

Top

Answer #10 by - visitor
25/09/2005 @ 10:37
Anonymous
Hi Globs,

I don't totally understand what you did, but it seems to work.
This function is called at a rate which is set according to the smallest check interval of the concerned accounts.
If some of the accounts to be checked have a larger interval, they are skipped.
For these accounts, this implies that the actual intervals may not exactly respect the requested intervals, as they will be multiples of the smallest interval.
Just to be sure: let's guess my check intervals are:
  • Account 1: 5sec
  • Account 2: 7sec
  • Account 3: 9sec
  • Account 4: 11sec
This means there will be a "cycle" every 5sec and in cycle x these accounts will be checked:
  • Cycle 1: Account 1
  • Cycle 2: Account 1, 2, 3
  • Cycle 3: Account 1, 2, 4
  • Cycle 4: Account 1, 3
  • Cycle 5: Account 1, 2, 4
This way the longest gap between the original check interval and the actual check interval would be the time of the cycle -1 sec. Which should be OK.
I think it's not gonna be the biggest problem if the check interval is not exactly what it was set to (as long as users know). I guess this is a good compromise, especially since it would be hard to check each account by it's original interval and just use the synchronous way if two (or more) accounts conflict - because it's not easy to say when accounts will conflict (they might even if the are not checked at exactly the same).
Anyway, here is a beta versionI would like you to test before I release it. Hope it will work for you. If it doesn't, I think I just have to frown
OK, I have to omit my testing was kind of hardcore - but this is what testing is all about, isn't it?
So here is how I managed to get the error again:
  • Check interval for two accounts both at 10sec
  • sending a mail to one of these accounts with a 7 Mb attachment
    • using a 2000 kbit/ sec downstream line the download time couldn't get better than 28 sec
    • this way I got the error twice
But I think this is not too bad. I'm not sure if thunderbird itself tackles this problem - but I might not happen too often because it's just possible to set up the interval in minutes.
This just means the user has to set a check interval working with the speed of the internet connect he is using - so it's up to the user to decide if he wants to get the error message...

I'm not sure if it's possible to skip a cycle if the another download is still running or if it's possible to check if the folder is still being processed. But as I said this would just be a bonus to make it perfect.

THANK YOU SOOOO MUCH FOR TACKLING THE PROBLEM!!!
GLOBS, YOU ROCK!!!

Toby
Write to Post an answer

Top

Answer #11 by Globs - rank ( 22 messages )
25/09/2005 @ 15:24
Globs
Hi,
thank's for your tests, Tobi.
I'm glad to know it's working in a standard situation. For the hardcore test, I was guessing we would still encounter the problem. To solve this one, I would really need a way to poll the folder and find out if it's still locked, but I could not find this info anywhere.

Dixit...
This means there will be a "cycle" every 5sec and in cycle x these accounts will be checked:
  • Cycle 1: Account 1
  • Cycle 2: Account 1, 2, 3
  • Cycle 3: Account 1, 2, 4
  • Cycle 4: Account 1, 3
  • Cycle 5: Account 1, 2, 4

Not exactly. The way I did it, Accounts 2 and 3 should get a 10 sec interval and Account 4 a 15 sec interval:
  • Cycle 1: Account 1
  • Cycle 2: Account 1, 2, 3
  • Cycle 3: Account 1, 4
  • Cycle 4: Account 1, 2, 3
  • Cycle 5: Account 1
  • Cycle 6: Account 1, 2, 3, 4

Site web Globs Write to Globs Post an answer

Top

Answer #12 by TheLod - visitor
26/09/2005 @ 14:41
Anonymous
the beta version seem to work fine...

Thx a lot, great tools for thunderbird !!!! wink
Write to TheLod Post an answer

Top

Answer #13 by Globs - rank ( 23 messages )
27/09/2005 @ 00:38
Globs
OK, great.
Thank's to both of you.
I released the beta as the official 0.6.4.
I'll add an explanation about this new behaviour in my usage page when I can find some time cry...
Site web Globs Write to Globs Post an answer

Top

Answer #14 by Toby - visitor
09/10/2005 @ 19:10
Anonymous
Hi Globs,

I'm sorry to tell you I got some problems.

Sometimes the poll interval is what I set it to, sometimes it just takes 1 1/2 hours until the next cycle of getting mail.
There are 4 Accounts o­n the same server all of them are set to 120sec
o­ne account set to 600sec
o­ne account set to 1200 sec
All of them are pop3 and use the global inbox

The news account is set to 100min

Since I deactivated automatic polling for the news account  and set the time to 0minutes. I did not have the problem any longer.
Could it be the 100min in the news account somehow confused yamb?

o­ne other problem I had is the following: o­n o­ne of the accounts there is a minimum poll time. If I get mails more often there will be a error message. When I get mails manually it looks I usually get a error message the next time yamb gets mails. Would it be possible to start a completely new cycle after manually checking mails?

Toby
Post an answer

Top

Answer #15 by Globs - rank ( 26 messages )
11/10/2005 @ 16:56
Globs
Hi Toby,
I'm very sorry about that.

Dixit...
Since I deactivated automatic polling for the news account  and set the time to 0minutes. I did not have the problem any longer. Could it be the 100min in the news account somehow confused yamb?


I read my code again and again but can't find any connection  between  the pop3 global inbox check, and the news (nntp) check. And I don't manage the rss check. (I don't know if you speak about a nntp or a rss account when you mention your news account).
My conclusion would be that you did not encounter this error after cancelling the news check just by chance, but I'm not very confident about this. Anyway, if there is a link, I don't see where and how.

Maybe you could try to change the 100 minutes setting ? For example, get the news account every 60 minutes, and see if sometimes you o­nly get your pop3 accounts every hour ?

Dixit...
Would it be possible to start a completely new cycle after manually checking mails?


For this, I must hook o­n the GetMail button (and menu) to call a Yamb function. This may be possible, but is likely to break every other extension which does the same thing. I'll have a look, but this will probably not definitely solve your problem:
there still is the standard automatic mail check of Thunderbird, happening about 60 times less often, and which may cause the same trouble. (In fact, yamb does it's mail check, considering the mail biff interval in seconds, but Thunderbird keeps going with it's own checks considering the interval in  minutes).

Site web Globs Write to Globs Post an answer

Top

Answer #16 by Globs - rank ( 27 messages )
11/10/2005 @ 17:43
Globs

Dixit...
For this, I must hook on the GetMail button (and menu) to call a Yamb function. This may be possible, but is likely to break every other extension which does the same thing. I'll have a look


Nope. I can't do it in a clean way. There are too many ways to access the getmail function, and some of them are dynamicaly built.
Site web Globs Write to Globs Post an answer

Top

Answer #17 by Toby - visitor
14/10/2005 @ 08:46
Anonymous
I'm pretty sure it's not just by chance. I tested it for 10 days. But I'll keep testing and let you know as soon as I know more. The weird thing was that sometimes it worked for a while and than it stopped working. The connection to the rss-Account was the only thing I could imagine.
About the GetMail thing: it's better to get the error message once than having problems with other extensions...

Toby
Post an answer

Top

Answer #18 by Toby - visitor
17/10/2005 @ 15:42
Anonymous
OK, looks like the 10 days where not enough... Today I had the same problem although the rss-Account is set to 0 minutes...
Post an answer

Top

Answer #19 by Globs - rank ( 32 messages )
17/10/2005 @ 15:54
Globs
And when the problem happens, how do you manage to get it working again ? relaunch TB ?
Next time it doesn't work, could you please try to open the yamb preference box and click OK. This will cancel all interval timers and start them again.
I already saw some true bugs with interval javascript implementation. If this helps, I could maybe init them every few days...

Site web Globs Write to Globs Post an answer

Top

Answer #20 by Toby - visitor
18/10/2005 @ 19:30
Anonymous
Hi,

just had the same problem again today. I opened the preference box and clicked OK - no change...
Unfortunately it's kind of difficult to test if it works OK or not. I always have to send a email to my own ID, wait,... Would it be difficult to add a debug option which just writes to a file the accountname and the time of each check? This would help a lot to find get more information.

Toby

Post an answer

Top

Start Previous one [ 1 2 ] Next one End

^ Top ^

GuppY - http://www.freeguppy.org/    Site powered by GuppY v4.5.14 2004-2005 - CeCILL Free License   GuppY - http://www.freeguppy.org/

Document generated in 0.22 second