Faire un don pour aider au developpement de WiPhA



 Nombre de membres 29 membres

Utilisateurs en ligne

( personne )

 147701 visiteurs

 10 visiteurs en ligne

forum.gifForum - Web iPhoto Access - Sujet n°47

Sujet n°47 Photo viewing problem
    par MacNeo - visiteur
le 28/01/2006 @ 14:26
First of all, i had a little installation problem. It didn't uncomment the 2 PHP modules in the config file, so i had to do it manually.
Then it all worked fine, except that... i can't see the photos!
I have grey squares, with the photo names under them... but no picture at all. Using Safari there's the "?" icon, as if the path to the image is incorrect and he can't find it.

I've already tried fixing permissions with Disk Utility, but the problem is still there.
Poster une réponse

Réponse n°1 par Globs - rank ( 81 messages )
le 28/01/2006 @ 15:57

would it be possible that you send me a copy of your original httpd.conf, so that I understand why I failed in updating it ?

Fixing the permission with DU will not help: it only fixes the files it installed itself.
There is basically 2 things to check:
  • The image URLs are correct
  • Your images permissions let www access them.
look in the page source; you should find some img tags sith src attributes like
ipl is a link in $­HOME/Sites/wipha, pointing to your iPhoto library (which is expected to be called exactly "iPhoto Library")

your $­HOME/Pictures folder, your iPhoto Library folder, and all folders inside msut have o+x access, and image files must have o+r.
You may also check that the changeperm program in the wipha folder has u+s perm (-rwsrwxr-x).

Hope this helps
Site web Globs Ecrire à Globs Poster une réponse


Réponse n°2 par AndyHewitt - visiteur
le 29/01/2006 @ 13:57
Hi Glob

I have also got exactly the same problems. I managed to sort the httpd.conf file manually (I used Web Settings Assistant). It seems the files are actually named with php4 in their titles - could be why your installer didn't find them.

I also cannot see any thumbnails when I view the search screen. In safari clicking on the magnifier brings up a blank window, in FireFox the image does appear.

Selecting all the images and downloading them does work though.


Ecrire à AndyHewitt Poster une réponse


Réponse n°3 par Globs - rank ( 93 messages )
le 29/01/2006 @ 14:57
here again, it seems that the  installer didn't do it's job at all; your missing pictures issue is all about permissions: in the wipha folder, do you have a changeperm executable with permission -rwsrwxr-x ?
It's goal is to set your photo library files and folder permissions so that wipha is allowed to access them.
It won't work is it doesn't have the "s" in it's permissions.

But what's strange is that you were able to access the images to download them. Maybe the problem is different ? You should also have a look in the apache error log (/var/log/httpd/error_log), and copy here what seems relevant to the problem.

Could you be more accurate about the filenames explanation ? I really need to understand why to install goes wrong sometimes, to improve the process. You could send me your original httpd.conf file ?

By the way, the magnifying glass doesn't work on Safari anyway with WiPhA 0.6 . I corrected that yesterday evening confused.
Site web Globs Ecrire à Globs Poster une réponse


Réponse n°4 par AndyHewitt - visiteur
le 29/01/2006 @ 15:48
Hi Globs

I saw your fix for the Safari problem just after I posted this.

I've checked the permissions for the 'changeperm' file, and they were weird - it had set me as the owner, and group, and set read and write, and read only. No wonder. Anyway, I've chmod'd the file to the permissions you suggest, but that still doesn't work.

My Access log shows these errors

[Sun Jan 29 14:29:12 2006] [error] [client xx.x.x.xx] Symbolic link not allowed: /Users/username/Sites/wipha/ipl/


sh: line 1: ./changeperm: Permission denied

(I've changed the IP address and username)

Thanks for the help, and as far as it goes, Wipha seems an excellent package.


Ecrire à AndyHewitt Poster une réponse


Réponse n°5 par Globs - rank ( 94 messages )
le 29/01/2006 @ 15:57
Ok, I know what is the problem:
symbolic link not alowed

--> does not take in account my .htaccess which allows links.

--> <user>.conf has not been updated to take .htaccess in account.

go an edit your /etc/httpd/users/<user>.conf file
replace 'None' by 'All'.
Then it should be ok.

But the real question remains: why did the installer failed to set all this automaticaly ???

Site web Globs Ecrire à Globs Poster une réponse


Réponse n°6 par AndyHewitt - visiteur
le 29/01/2006 @ 16:48
Hi Globs

I have an 'AllowOverride', which is set to 'None', If I set it to 'All' I can't log into the site.

There is an 'Allow from', from that is set to 'All' already.
Ecrire à AndyHewitt Poster une réponse


Réponse n°7 par Globs - rank ( 95 messages )
le 29/01/2006 @ 16:52
AllowOverride must be changed to All.

Then, let's keep investigating what's still wrong...
Site web Globs Ecrire à Globs Poster une réponse


Réponse n°8 par AndyHewitt - visiteur
le 29/01/2006 @ 18:42
Aha, right, that did the job cool

It did a strange thing though, on the first login attempt it asked for my local admin username and password. I tried all that I normally use but none worked. It turned out to be my master level password for the entire system, and then it went straight into Guest access. I find that one quite worrying.

Considering all the files that I've had to alter were either installed, or supposed to be modified by, your installer, I think that's what needs looking at.

Ecrire à AndyHewitt Poster une réponse


Réponse n°9 par Globs - rank ( 98 messages )
le 29/01/2006 @ 18:50
I don't know what happened with passwords during all your tries. Maybe you made a mistake.
What's sure is that if you disconnect from wipha, then remove the file wipha/data/users.ser (which stores wipha accounts), next time  you'll try to login, it will require the default wipha admin login/password which is admin/admin.
Site web Globs Ecrire à Globs Poster une réponse


Réponse n°10 par AndyHewitt - visiteur
le 29/01/2006 @ 18:58
No, it didn't ask for my wipha login, it asked for my 'username.local' admin password, which turned out to be my OSX master password. This was in a Safari dialogue, not the wipha login screen.
Ecrire à AndyHewitt Poster une réponse


Réponse n°11 par Globs - rank ( 99 messages )
le 29/01/2006 @ 19:02
Oh, yes,
that's because you probably told Safari to remember the password before and OSX stored is into your keychain. Then, when the password is needed again, OSX takes it in the keychain and ask (sometimes, and too often imho) for your account password to access the keychain.
Site web Globs Ecrire à Globs Poster une réponse


Réponse n°12 par AndyHewitt - visiteur
le 29/01/2006 @ 19:05
Yes, that's a possibility. Anyway, all resolved for now. Thanks.
Ecrire à AndyHewitt Poster une réponse


^ Haut ^

Site non déclaré à la CNIL dans le cadre de la dispense n°6
Vous disposez d'un droit d'accès, de modification, de rectification et de suppression des données qui vous concernent via votre profil.
GuppY -    Site créé avec GuppY v4.5.14 © 2004-2005 - Licence Libre CeCILL   GuppY -

Document généré en 0.39 seconde