Faire un don pour aider au developpement de WiPhA



Se reconnecter

Votre nom (ou pseudo) :

Votre code secret

 Nombre de membres 117 membres

Connectés :

( personne )

 1812613 visiteurs

 11 visiteurs en ligne

forum.gifForum - External Editor - Sujet n°353

Forum - Forum
External Editor - External Editor

actif  Sujet n° 353  Empty file opened in Maverick and Thunderbird 24

le 07/11/2013 @ 18:22
par rkrug



I am using Thunderbird 24.1.0 on Maverick, and try to use emacs as my externl editor.
My problem is that Thunderbird, upon calling "external editor", does not seem to save the email, as in emacs an empty file is opened (with the name SUBJECT_alongnumber.eml in the folder /tmp/).
This is now always happening, after initially it worked once.
I have write access to this folder, so it is not a problem from this side.
I am using it on a Macbook Pro Retina, and haven't tried it before the upgrade (was using GNUS then).
Any ideas what is happening?
  Poster une réponse  Haut


Réponse n° 1
le 10/12/2013 @ 17:11
par rkrug


OK - I solved it. One has to use the -W option when specifying the editor and using the open command. From the manual of open:

-W  Causes open to wait until the applications it opens (or that were already open) have exited.

I now have:

open -W -a Emacs --args -Q

and it works nicely.

  Poster une réponse  Haut
Réponse n° 2
le 13/03/2014 @ 22:01
par Saibot


I have a similar problem: my editor opens an empty file, which is consistent with the fact that Thunderbird does not create any file in /tmp before the editor is called. Moreover, when I use my editor to compose a message, save, and quit, no content appears in Thunderbird.

Any ideas? I don't think that the previous user's solution is applicable to me since I don't use "open" or even know what it is.

I am on Gentoo Linux with Thunderbird 24.3. External Editor calls this script to fire vim:

urxvtc -e zsh -c "vim $@"

I also use this for Firefox with the analogous "It's all Text" extension and it works perfectly.

Thanks for any hints!
Ecrire à Saibot   Poster une réponse  Haut
Réponse n° 3
le 16/03/2014 @ 00:05
par globs


I know nothing about urxvtc, but a small search found the following:

"Currently, it always returns immediately after contacting the daemon."

Which is consistent with the fact you find no file in /tmp. It is deleted immediateley after urxvtc returns.

Now, I don't explain how this works with IAT in Firefox s
Ecrire à globs   Poster une réponse  Haut
Réponse n° 4
le 03/04/2014 @ 00:51
par saibot


Thanks, globs! Not calling the daemon for requesting a new terminal indeed did the trick. So this is my new script:

urxvt -e zsh -c "/usr/bin/vim $@"

Now I can finally compose emails in my favorite editor l
  Poster une réponse  Haut
Réponse n° 5
le 16/06/2014 @ 10:27
par Grateful


Hallelujah!  Thanks so much rkrug.

Before: dkd

After: l
  Poster une réponse  Haut
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message   -   Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter
Catégories de discussion  Forum 

^ Haut ^