Faire un don pour aider au developpement de WiPhA



Se reconnecter

Votre nom (ou pseudo) :

Votre code secret

 Nombre de membres 126 membres

Connectés :

( personne )

 2634190 visiteurs

 9 visiteurs en ligne

forum.gifForum - External Editor - Sujet n°365

Forum - Forum
External Editor - External Editor

actif  Sujet n° 365  Can't Add External Editor to Toolbar

le 30/07/2017 @ 10:05
par apwhewett


Death of my laptop forced me to move to a new computer and configure Thunderbird with all of my add-ons, including one of my favorites, External Editor.  I installed the beta version for TB 52, as required to get the preferences to work,  but when I went to add External Editor to my toolbar from the Customize menu, there was no External Editor among the choices.  I thought this might be due to the fact that I was moving to a Linux OS from a Windoows 10 environment, but when I attempted the same setup procedure on my wife's W-10 laptop, there was also no External Editor choice on the Customize menu.  Unless I am missing something, is there a way to get the External Editor choice onto my toolbar?

Pardon me - stupidity here.  My problem is NOT that the external editor isn't showing on the toolbar.  Naturally it only shows on the toolbar when you are writing a message.  Duh!  But I am having a problem in the Linux environment.  If I set the editor to gedit, things work properly.  If I set it to gvim, they do not.  When I watch /tmp, I see that with gedit, a temporary file shows up and that is the file I'm editing.  With gvim I see a swap file show up, but no normal temporary file and gvim complains the file is no longer available.  If I make changes and then do a write, thus creating the file in /tmp, Thunderbird doesn't see the changes and they don't show up in my message and the temporary file remains on /tmp instead of disappearing.

P.S. When I attempted to add this message using Chrome, I could not type in the composition box.  I had to go to Firefox to be able to compose this message.
Rectified by apwhewett 31/07/2017 @ 12:36
Ecrire à apwhewett   Poster une réponse  Haut
Réponse n° 1
le 02/08/2017 @ 00:03
par apwhewett


I finally worked out a solution (thank goodness).  It seems that gnome.terminal has some kind of negative interaction with vim and Thunderbird.  When I went from gvim to "xterm -e vim" the problem went away.  gvim points to vim.gnome and when I tried "gnome-terminal -e vim" I also had the problem.  With xterm, there were no problems.  Once I could edit message content with vim, I was much happier.
Ecrire à apwhewett   Poster une réponse  Haut
actif sujet actif   clos sujet clos   Important! Important!   Nouveau Nouveau message   -   Rectifier Rectifier message   Clôturer Clôturer sujet   Remonter Remonter
Catégories de discussion  Forum 

^ Haut ^